[Urwid] problem installing urwid

Ian Ward ian at excess.org
Tue Nov 22 08:52:23 EST 2005


Jeff Roberts wrote:

>Hello,
>
>Running CentOS 3.5, with python2.2.  I get this when i run the installer:
>
>[root at ajack urwid-0.8.0]# python setup.py install
>
...

>distutils.errors.DistutilsPlatformError: invalid Python installation:
>unable to open /usr/lib/python2.2/config/Makefile (No such file or
>directory)
>[root at ajack urwid-0.8.0]#
>
>Does anyone have any ideas as to what is wrong?  I am a total python
>newb so it might be something obvious.
>  
>
I've seen something similar when I try to install with the setup script
on Ubuntu.. It seems like python's distutils is broken.  You could use
the "Local Install" method:
 http://excess.org/urwid/#htoc9
Or you could manually copy the inner urwid directory into your
site-packages directory, probably:
/usr/lib/python2.2/site-packages

By the way, urwid 0.8.0 is more than a year old now, you might want to
upgrade :-)

Ian




More information about the Urwid mailing list